Device Disconnected

Hi there

We brought a Huion GT220 V2 for my son for last Christmas and its 29th March and we have still not managed to get it set up correctly!

I have just brought a new computer as my previous laptop was very old and I thought that this might just be stopping me from setting up correctly - however, I still cannot get the Device Connected message and I just don't know what I am doing wrong???

Can anyone please help me!

With many thanks, Andria

2 people have this question
  • Hi Lozza S, when you installed the driver, did it consistently show as "Device disconnected"? May I know what driver versions you've installed? Since you mentioned that you've had it a few years now, it is possible that you have the H610Pro with 2048 pen pressure. Kindly install the driver found in this link: Huion H610Pro (2048) Graphic Tablet Drivers. Please let me know the operating system you are using as well.

    Best Regards,

    HUION Customer Support.

  • I'm having the same problem with a h610 pro. I've tried installing on 3 separate laptops and two different usb cables. I download the driver but the tablet never seems to connect. Why won't it work?We've had this in a box for a few years now and have never been able to get it working no matter what we try.

    1 person likes this
  • Hi Steven Jennings, thank you for sharing the steps you did. I've referred this to our technical department and what you did was a valid method that can be used in case the more recent driver version doesn't work right away. 

    Best Regards,

    HUION Customer Support

  • I was able to solve the issue myself.

    1. Download Driver version
    2. In the settings (the small cog icon in the top right), go down to "Check for Updates". Allow this to run with internet access and it will notify the user that there is a new udate.
    3. Allow the update to be downloaded and run the update (note : this DOES NOT download the driver that is provided on the main website. Rather, it downloads driver_v14.8.73.993_beta)
    4. I received a continues stream of "could not complete due to overwrite issue". Solved this by deleting what was left of Huion Tablet in my C:\ drive and then re-ran the update.
    5. Finished update and everything works fine.

    Update the provided driver on the website. The newest driver provides hotkey profiles for the user which has been around for other providers for a long time. This update is extremely useful. Not just bug fixes.

  • Hi Steven Jennings, kindly try these methods:

    1. When you see the "Administrator privileges" button at the lower part of the tablet driver, please click it and check if the driver works.

    2. If your don't see the the Administrator privileges" button, uninstall the tablet driver, go to C:\Windows\SysWOW64, delete the wintab32.dll file then reinstall the latest tablet driver. Note: Make sure your antivirus is turned off, all drawing programs are closed and your tablet is not connected to your computer when reinstalling the driver.
    3. If the first 2 steps above won't work, you can just continue using Driver version The difference between the two driver versions are minimal and are usually just about some debugging done for certain models.

    Best Regards,

    HUION Customer Support

    1 person likes this
  • I have a similar issue.

    I have the 8192 variant, and there for have been getting my drivers from said section.

    The tablet works fine on Driver_14.7.154.586  but as soon as I update to Driver_14.8.90 , the tablet is no longer detected.

    I have tried doing a clean uninstall/reinstall and swapping cables, but to no avail.

    I believe 14.8.90 is just bugged.

  • Hi Andria Geal, there are 2 versions of GT-220 v2; one with 2048 pen pressure and another with 8192. May I know the following information so I can assist you further: 

    1. The version of the tablet driver that you've installed
    2. Your computer's operating system
    3. Your tablet's serial number (found at the back)

    The reason why your tablet driver shows as "Device disconnected" is due to one of the following reasons:

    • The cable was not securely plugged in to the USB port
    • The USB port or the tablet's port is defective
    • The USB cable is defective
    • The wrong driver or an out-dated one was installed

    Thus, if you are experiencing this issue, please try the steps below and see if it gets resolved:

    • Make sure that the USB cable is connected securely, and the USB port is functional.
    • Use another USB cable and/or connect the USB cable to another port.
    • Change to another computer, if possible, to see if the issue still persists.
    • Re-install the latest driver from the Huion Official website using this link: Huion GT-220 v2 (2048 and 8192) Pen Display Drivers

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment