Device Disconnected

Hi there

We brought a Huion GT220 V2 for my son for last Christmas and its 29th March and we have still not managed to get it set up correctly!

I have just brought a new computer as my previous laptop was very old and I thought that this might just be stopping me from setting up correctly - however, I still cannot get the Device Connected message and I just don't know what I am doing wrong???

Can anyone please help me!

With many thanks, Andria

2 people have this question
  • Hi  Fabrice Papahn, Thank you for getting back to us. We are very glad to hear the problem is solved.

    That is correct; you cannot plug both the HDMI and USB-A to 1 USB-C port. They must be separate. Anytime you encounter a problem with our products, please feel free to contact us. We will do our best to help you.

    Hoping you have a great day and enjoy your tablet!

    Best regards, 

    HUION Customer Support

  • The solution was the port. Each port must to be independant (hdmi to usb c, usb to usb c).

    Important :  a big hub with usb, hdmi, usbc,... doesn't work at all!

    I tried with an old version with a macpro from 2011 : Mac 10.11.6 (El capitan) and it's working!

    So, it is not a question with virus or version on mac, only with port.

  • Hi  Fabrice Papahn,  please try the steps below that may help resolve your issue: 

    1)Please make sure that the USB cable is connected securely, and the USB port is functional;

    2)Change to another USB port;

    3)Change to a different computer;

    4)Re-install the latest driver 

    Please uninstall the driver you are using now, unplug the tablet, and close all the drawing programs and anti-virus software before installing the new driver. Then re-plug the tablet in.

    Here's a step by step instructions on how to reinstall the driver:
    * Log out from the Huion driver, close all drawing programs you are running, and close your anti-virus software.
    * Uninstall the Huion driver from the Control Panel.
    * Unplug the USB cable.
    * Download the latest driver from the Huion website.
    * Reboot your computer.
    * Plug the tablet back in.

    Moreover, please reply to us in the ticket and provide the product information so we can help resolve your issue.

    Best regards, 

    HUION Customer Support

  • Hello, I bought a huion kamvas 16 tablet and I use a macbook pro with mac os 10.13.3 High Sierra (usb c connections). I download the last driver but "device disconnected". i went also to Mac System Preferences > Security & Privacy > Privacy > Accessibility and it stills disconnected. how to connect it? 

    (603 KB)
  • Hi Elena Zarza, the reason why the 14.4.4 driver version shows "Device disconnected" is because this is the wrong driver version for your tablet. Based on your serial number, your tablet model is the H610PRO(2048), thus, the Driver_12.0.4 version is the one compatible to your tablet.

    Please go to Mac System Preferences > Security & Privacy > Privacy > Accessibility and make sure that you add HuionTablet and TabletConsole apps on your whitelist. Usually, this is the main cause why the driver recognizes the tablet but the pen won't work. When the necessary apps are added on the whitelist, the pen issue will then be resolved. Restarting the computer or uninstalling and reinstalling all over again will also help if you are unable to get the pen to work after doing all these steps the first time. 

    NOTE: Do not just drag the Huion Tablet driver app to your trash to uninstall it. This is not the proper way. You need to find the Huion Tablet folder and click on the uninstall program to properly uninstall the driver. Improper uninstallation will cause issues as well.

    Best Regards,

    HUION Customer Support

  • Hi,

    I'm having the same problem with a H610 PRO (purchased on 2016).  I downloaded the driver ( but appears "devise disconnected", but when I use the drawing software, the pen works with no pressure (I rebooted the computer after installation). Then proceeded to uninstall the driver and installed this driver (12.0.4) Now appears "device connected" but the pen doesn't work. Why this is happening? Which is the correct driver?

    Additional details

    ✭ I have a Mac with Catalina OS

    ✭ S/N H610PRO15121983

  • I'm having the same problem with a h610 pro (purchased on 2016). I downloaded the driver (Driver_14.4.4.191025) but appear "device disconnected", I can use with drawing software but with no pressure. Then uninstalled the driver and installed this driver (Driver_12.0.4) Now the appear 'devise connected" but the pen doesn't work. Why this is happening?

    Additional details:

    ✭ I have a Mac with Catalina

    ✭ S/N H610PRO151210983

  • Hi Martin Begley, MD, thank you for sharing your experience and we appreciate your feedback on our instructions. We will review our installation instructions and update it accordingly. We're glad that your issue has been resolved as well.

    Please feel free to let us know what else we can do to further improve our products and services. Thank you!

    Best Regards,

    HUION Customer Support

  • Hi, 

    I had a DEVICE NOT CONNECTED problem with my KAMVAS 16 Pro. I searched through he Huion support and also viewed some Youtube videos. Then I followed the suggestion that I should uninstall the driver and reinstall it having other tablet drivers and all anti virus apps off. I deinstalled my Wacom drivers and turned off my Malwarebytes program.

    I did those things and still had the problem and serendipitously, I saw a comment saying that after installing a driver, I should reboot. I did this and now my device is working.  Fingers crossed!!!

    Once rebooting was necessary for the complete install of most programs but no longer. I feel that Huion is not serving its customers by not giving good step by step instructions for set up and other tasks. It seems the instructions were drafted by folks who are using the product everyday, for a long time and probably were involved in development. What is needed is a technical writer whose  training and experience are in creating guides for the person with no experience with computers at all so each step is detailed. Anyone who in writing a guide looks at a step and assumes, "Don't have to put that  in. Everybody knows that."  is doing the customer and company a disservice. One of the major drivers of return business is the ease of getting the product up and running!!!!!

  • Hi Arrigoni, Francesca, you are right; since your tablet works fine on your daughter's PC but not in your MacBook Air, the issue is with the software. Since your MacBook Air is running on Mojave, kindly install Driver_14.3.11.190506 or Driver_14.3.10 version. When uninstalling your tablet driver, please make sure you don't just drag it to your trash. Instead, properly uninstall it using the Uninstall button in the driver or the uninstall application. You can check out this video on how to properly install and uninstall the driver: How to Install/Uninstall Huion V14 Driver on Mac OS (Video) and these articles as well: How to Uninstall the HUION MAC Driver V13 or V14 Properly and How to Install Huion Driver on MacOS.

    Remember, do not connect your tablet to your computer, turn off your antivirus and close all your drawing programs while installing the driver.

    Best Regards,

    HUION Customer Support

  • My Mac book air  is operating on Mojave. The pen was working fine (GT-191; 8192)last week, today nothing. device disconnected.

    I have taken off and reinstalled the drivers. Installed older drivers and tried to update - but the 'device is disconnected' keeps showing).

    I tried it on my daughters PC, downloaded the PC driver, which was a lot more thorough as a process. Everything connected and the pen worked fine on her pC. 

    Its not the hardware or  wires, its my computer and the drivers have somehow become incompatible. I read somewhere that maybe my computer can turn it into sleep mode, but I have turned this off and it hasn't worked.

    Any Ideas?


  • Hi Aaron Harris, kindly try the steps found in this article: What To Do When Huion Driver Shows Device Disconnected?. Since you've already done Method #1, you can skip to Methods #2 & 3. Kindly answer the following questions as well:

    1. Does the tablet light turn on when you touch the pen on the tablet surface?
    2. Does the tablet light turn on when you press the tablet's buttons?
    3. What operating system are you using?

    Best Regards,

    HUION Customer Support

  • my h1161 disconnected i tried reinstalling the driver like5 times that didnt work. how do i reconnect it

  • Hi elena menjon, are you using an adapter in connecting the 3-in-1 cable to your Mac computer? If you do, please try to change your adapter and try using a different port. If the tablet is displaying the screen, then the HDMI end of the 3-in-1 cable is working fine. The issue lies on the USB end of the 3-in-1 cable or the USB-C end that is connected to your tablet. Please try connecting it to a different USB port as well.

    If you have an access to a different computer, please try it with a different one and check if the issue persists. Do you have access to a Windows computer? Please let me know if you do, so I can send a software that can test your tablet's performance. 

    After all the applicable tests are done and if the issue is still the same, it is possible that the issue is caused by your 3-in-1 cable since it kept on showing "Device disconnected".

    Best Regards,

    HUION Customer Support

  • Hi

    I have the same issue. I have a GT 156 HD V2 and using Catalina Mac OS. I downloaded the latest driver from the original website. Installing - uninstalling. Plug-in, plug off, switch on and off my computer and also changing the settings in Security in System preferences.

    The "device disconnected" keeps appearing. It´s weird cause the tablet is working as I can see it as a second screen and I can drag programs to the tablet, but I can´t use the pen :(

    Does anybody have any idea at this point?

    Thanks a lot in advance 

Login or Signup to post a comment